Right-click for options

Right-click for options

Right-click for options

Right-click for options

GoDaddy Ultimate Linux Hosting Install Error: How to solve it?

Right-click on block content for options

Right-click for options

Right-click for options

  • Member
    Ashok Sharma Author 1 year ago

    Please guide me, a novoice dealing with it. But I handle Drupal sites succesfully. Now the version 8 has very heavy codebase so searching for lightweight solution to handle lot of 10-15 pages websites.

    I have created a free hosted site with Builder Engine and too much impressed, everything looks very promising,and intend to use and promote as online voluneer but stuck with install.

    Below is full text of error:

    A PHP Error was encountered

    Severity: Warning

    Message: mkdir(): Invalid path

    Filename: drivers/Session_files_driver.php

    Line Number: 117

    A PHP Error was encountered

    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at /home/futureonline/public_html/futureinternet.online/system/core/Exceptions.php:272)

    Filename: core/Common.php

    Line Number: 568

    An uncaught Exception was encountered

    Type: Exception

    Message: Session: Configured save path '' is not a directory, doesn't exist or cannot be created.

    Filename: /home/futureonline/public_html/futureinternet.online/system/libraries/Session/drivers/Session_files_driver.php

    Line Number: 119

    A PHP Error was encountered

    Severity: Warning

    Message: fopen(5018c17ebd546d76452ab96ffff9b84b413251da): failed to open stream: Permission denied

    Filename: drivers/Session_files_driver.php

    Line Number: 156

  • Member
    Power Chaos Reply 1 year ago

    This means that you need to set a php setting

    in php.ini you need to set the following

    session.save_path = "/tmp"

    instead of session.save_path = ""

    ask your host to do that for you , or ask them if they support custom php ini

    default in php is there no session path set , but it should take the defaulth path normaly ( no reason why , but this is the first script i need to specific assign a session path to get it working :s ) 

     

    Greets From PowerChaos

  • Admin
    Keith Killilea Reply 1 year ago

    Thanks for your posts on this. The standard for Linux hosting normally includes "/tmp" as the session path but sometimes hosting companies decide to use another name. We will look at a future update for the CMS platform to include in the install a session path option to change it if a hosting company uses something other than "/tmp".



Posting to the Forum is only allowed for members with active accounts. Please Sign In or Register Account to post.

Right-click on block content for options